Gretsch - Replacing All Heads

Pearl, Tama, Yamaha, DW, Ludwig, Premier, Mapex etc.

Moderator: Moderators

User avatar
dannycareyisgod
drumming adept
drumming adept
Posts: 79
Joined: Sun Oct 21, 2007 4:52 pm
Location: Charlotte, North Carolina

Post Fri Jan 01, 2010 4:24 pm

kplante069 wrote:You do know the Gretsch uses G1's as factory reso's, right?

They only use the G1 Clear reso's for the Gretsch Renown kits.
Gretsch Catalina Maple-------> 22" x 18" bass, 10" x 8" and 12" x 9" toms, 14" x 14" floor tom, 16" x 16" floor tom, 6" x 14" snare.

Zildjian A Customs-------> 20" ride, 16" crash, 18" fast crash, 14" hi-hats.
Drumosaurus
groove master
groove master
Posts: 2058
Joined: Wed Aug 08, 2007 10:51 am
Location: indiana

Post Sat Jan 02, 2010 4:43 pm

for a good double pedal hihat stand, I reccomend pdp. I don't know what the model is, but it's the cheapest 2 leg pedal they have. it's a great hihat stand for only 68 dollars.
R.I.P. Jimmy "the Rev" Sullivan. You will be missed.
audiotech
drumming adept
drumming adept
Posts: 149
Joined: Sat May 03, 2008 6:17 pm

Post Sun Jan 03, 2010 3:28 pm

kplante069 wrote:You do know the Gretsch uses G1's as factory reso's, right?


I don't believe this is correct, at least it wasn't correct on my new Gretsch Renowns. The resonant heads on those drums did not have any logos on the reso heads at all. When I took the reso heads off the toms, they felt as if they were more like a 7 mil head instead of a 10 mil which is the thickness of an Evans G1 clear. I replaced all the 7 mil tom resonant heads with Evans G1 clear heads and the sound of the toms got a bit fuller and warmer sounding.

Dennis
User avatar
kplante069
drumming adept
drumming adept
Posts: 441
Joined: Mon Feb 05, 2007 3:56 pm
Location: Cumberland, RI

Post Sat Jan 16, 2010 8:15 pm

Whatever, to be honest at this point I could care less. It's what I was told by a reliable source. I'm happy with mine until I get around to changing them.
Image
jafo
beginner
beginner
Posts: 10
Joined: Mon Aug 09, 2010 7:35 am

Post Mon Aug 09, 2010 3:17 pm

Check your tom mounting system also. I had the two small screws that bolts the mount to the clamp that goes on the spur, they worked thier way loose on me. Or they were never real tight to begin with.